NVIDIA 1.0.9625 for Debian Sid

Hey guys,

just because the Debian Maintainer of the NVIDIA drivers is a bit lazy and does not yet have uploaded the new beta drivers to experimental (or unstable), I've created some nice debs including the patch from zander (nvnews.net) to deactivate the smbus feature, because it sucks!

Have fun with them:

deb http://debian.die-welt.net/ sid main contrib non-free
deb-src http://debian.die-welt.net/ sid main contrib non-free

Xorg 7.1 in Debian unstable und diesmal fast gar nichts kaputt

Gestern (bzw eher heute - was in incoming liegt zählt nicht) erreichte Xorg 7.1 endlich Debian Sid/unstable. Grud dafür ist u.a. die Absicht, 7.1 in Etch im Dezember auszuliefern.

Wer sich an das 6.9 zu 7.0 Update erinnern kann, weiß dass sort vieles kaputt war, nach dem Update. Diesmal ist es nicht so. Ich hatte bereits seit paar Wochen die experimental Pakete von 7.1 laufen, und das einzige was mir aufgefallen ist, dass man nvidia-glx aus experimental braucht, da von 7.0 auf 7.1 in Xorg eine Veränderrung der ABI stattfand und man sich bei der XStrikeForce von Debian dazu entschieden hat, bei den Vide-Treibern nicht mehr xserver-xorg-video sondern xserver-xorg-video-1.0 haben zu wollen als MetaPaket. nvidia-glx aus unstable 'Provides: xserver-xorg-video' - und wird deswegen rausgeschmissen. Ein Paket das dieses Problem behebt ist in experimental und sollte hoffentlich bald auch in unstable landen.

Wie das Update mit ATI veräuft weiß ich noch nicht, da ich heute mein ThinkPad noch nicht gebootet habe.

Waiting for ish - finished

Ich hab ja gesagt, dass das Modem die neuen Einstellungen sich geholt hat, aber ich noch keinen SpeedBoost bemerken konnte.

Als ich dann gestern zuhause war, wartete der tolle Telefonie-Adapter von ish auf mich. Absolut sinnloses teil, da es nur Western/RJ11 auf das schwule Telekom TAE wandelt. Egal. Auf jeden fall funktioniert das Telefon jetzt.

Einen SpeedBoost konnte ich aber dennoch nicht festellen.

Jetzt sitzt ich hier im Büro und hab wegen was anderem mal meine /etc/network/interfaces geöffenet. Und was seh ich da? Auf eth2 (mein Interface wo das Modem dran hängt) wird wondershaper ausgeführt, ein Script für QoS. Und mit welchen Einstellungen? Richtig, nur 2MBit/s down - auf 6 geändert und es rennt.

Danke ish für meine Blödheit.

Waiting for ish - part 2

So, heute ist der 19.09. Heute sollte ish meinen neuen Anschluss freischalten, bzw umschalten.

Sitze grade im Büro und hab mal zuhause das Modem reseted. Dieses sagt nun auch brav Retrieved TFTP Config BE_Platin_2_CG4500_d.cfg SUCCESS (die alte Config hieß Best_Efforts_2M_512k_no_voice_d.cfg) - nur irgendwie scheint es davon nicht schneller geworden zu sein...
Weiter hinten im Log stand übrigens auch ein Resetting due to SNMP docsDevResetNow - da hat wohl jemand von außen das Dingen rebootet...

Wir warten mal ab...

Warum ich heute eBay nicht mag

Normalerweise mag ich eBay ja - man bekommt da relativ günstig alles mögliche und kann auch seinen alten Kram loswerden.

So wollte ich das auch mit meinem alten Sony Laptop machen. Schön beschrieben, Fotos gemacht und rein damit - Startpreis 1€ und 333€ SofortKauf.

Am nächsten Tag hat auch tatsächlich jemand auf den SofortKauf-Button geklickt. Eine gewisse Mrs Cindy aus London. Mit 0 Bewertungen und erst seit einem Tag bei eBay. Naja, was solls, jeder fängt mal klein an. Interessant war allerdings ihre Adresse: 1234 essex avenue - laut maps.google.de gibts aber auf der Essex Ave in London aber noch nicht mal ganz 100 Häuser...
Hab ihr also eine Mail geschickt, wieviel der Versand nach England kosten würde, das ich die zahlung gern per PayPal hätte und das ihre Adresse etwas komisch ausschaut.
Paar Stunden später trudelten Antworten von ihr ein. Die Adresse wurde auf 123 essex avenue korrigiert. Und der Laptop sollte für ihren Mann sein, der bei einer Öl-Firma in Nigerien arbeitet (na, klingt doch vertrauenswürdig). Dafür bräuchte sie bitte meine Adresse und Telefonnummer, damit sie ihrer englischen Bank sagen kann, dass diese mir Geld überweisen soll.
Hab also mal bei DHL geguckt, was Versand nach Nigerien kostet, und diese Info zusammen mit dem Hinweis, dass ich nur PayPal akzeptiere, an die Dame geschickt. Am nächsten Tag immer noch keine Rückmeldung von ihr - also noch ne Mail raus. Währenddessen mal die IP in den Headern der alten Mail gecheckt - Kanada, interessant.

Heute stand dann in "Mein Ebay": "Hinweis von eBay: Dieser Benutzer ist bei eBay nicht mehr angemeldet" - tolle Sache das. Mal "Nicht bezahlten Artikel melden" geklickt und mir die Verkaufsprovision gutschreiben lassen. Jetzt heute Abend den Laptop nochmal reinstellen. Diesmal aber mit einem netten Hinweis für die "International Bidder" - nur PayPal, nur EU, nur 10+ Bewertungen.

Was lernen wir daraus? Würde eBay mal konsequent die Adressen der neuen User überprüfen, wäre das nicht passiert. Aber hey, wir sind ja kein großes Online-Auktions-Haus und die Wahrscheinlichkeit, dass jemand uns für Betrugsversuche missbrauchen könnte tendiert gegen 0!

Vielen Dank fürs Zuhören

Waiting for ish - part 1

Mjoa, es ist nun 2 Wochen her, dass ich bei ish das neue 2play+ ANgebot bestellt habe. Seit dem kein Briefchen, kein Paket (es muss so ein Telefonie-Adapter kommen), nix.
Jetzt hab ich grade die nette Hotline angerufen, und die Dame am anderen Ende sagte mir, es wäre wohl gestern bearbeitet worden und sollte zum 19.09. fertig sein (natürlich ohne Gewähr diese Aussage). Begründet wurde die Verzögerung durch ein "hohes Auftragsaufkommen".

Da bin ich jetzt erstmal gespannt, wie das weitergeht. Gothseidank ist es ja nicht so, dass ich jetzt ohne Internet und Telefon zuhause sitze, deswegen kann ich ganz gechillt warten.

Aus zwei mach Eins - Panasonic Lumix FX8 reparieren

Meine wehrte Mutter hat vor einiger Zeit geschafft, ihre fast neue Lumix FX8 fallen zu lassen. Wie der Zufall so will, war der Untergrund nicht etwa ein langweiliger Teppich, sondern schöne Granitplatten. Das Resultat war entsprechend beendruckend, das 2.5" Display hatte einen sauberen Bruch von links unten nach rechts oben und das Modus-Auswahl-Rädchen (wie heißt der Scheiß eigentlich wirklich?) war eingedrückt.

Da meine Mutter nicht unbedingt wieder 250€ für eine neue Digitalkamera ausgeben wollte, durfte ich das Gerät reparieren. Also erstmal ab zu eBay und Ersatzteile besorgen. Hat keine Woche gedauert, da hab ich eine FX8 mit defekter Optik (das Objektiv ist ausgefahren und lässt sich nicht bewegen) gesichtet und ein paar Tage später für 35€ bekommen, 4€ Versand dazu und die Kiste lag heute früh bei mir aufm Schreibtisch.

Los ans Umbauen!

Zunächst die FX8 meiner Mutter auf: einfach die Schrauben links, rechts und unten lösen, dann kann man die Rückwand abnehmen. Vorsicht: merken, welche Schraube wohin gehört - sie sind unterschiedlich lang und machen später unnötig ärger! Das Display ist samt Backlight am Gehäuse festgeklebt, zum Mutterschiff - ups, Platine - führen 2 Flachbandkabel, ein breiteres vom Display und ein schmaleres vom Backlight.
Dabei hat das Backlight-Kabel eine Art Stecker, man kann es abziehn und wieder dranmachen an die Platine - beim Display-Kabel geht das nicht! Einmal ab - immer ab, oder zumindest bis man das "richtige" Werkzeug hat. Also mach ich die ganze Platine ab, kann ja sonst das neue Diplay nicht draufstecken.
Die Platine ist durch eine größere Steckverbindung mit der Platine darunter verbunden, einfach mit dem Schraubenzieher anhebeln und ab ist das Ding.
Jetzt muss noch das kaputte Modus-Auswahl-Rädchen ab, das sitzt im selben Block wie der Auslöser und der Einschalter. Um dieses Teil rauszunehmen (es hat wieder so eine tolle Steckverbindung zur zweiten Platine) braucht man etwas mehr Geschick. Zunächst muss man die Vorderseite der Kamera aufmachen. Die äußeren Schrauben sind ja alle gelöst, aber es sitzten noch 3 um das Objektiv herum - man muss den silbernen Ring, der um das Objektiv liegt leicht drehen und anheben, darunter befinden sich dann die Schrauben. Sind diese ab, kann man die Vorderseite aufmachen und mit sanfter Kraft die gesamte Oberseite der Kamera abnehmen - dazu gehört übrigens auch der Blitz-Akku.
Jetzt ist die Kamera von den defekten Teilen befreit, und man kann die Ersatzteile einbauen.

Aber erstmal muss man sie haben! Also die zweite FX8 aufgeschraubt - geht genauso wie bei der ersten, nur dass das offene Objektiv etwas stört, aber egal. Sobald man dann die Teile hat, die man braucht, ist es nur noch einfaches Zusammenstecken. Ich nehme den gesamten Oberteil der zweiten FX8 und stecke ihn auf die erste, ein leichtes "Klack" und es sitzt. Jetzt die Vorderseite dran, und zuschrauben, zunächst um das Objektiv herum, dann den Ring drauf. Kamera umdrehen und die neue Rückseite aufsetzen: Platine draufklicken und Deckel drauf. Jetzt alle Schrauben rein et voila! Mit Akku lässt die Kamera sich dann einschalten und funktioniert wie vor dem Unfall.

Nein tut sie nicht, also tat sie bei mir nicht. Sagte nur "Please turn the camera off and on". Dabei hab ich sie doch vor dem Festschrauben getestet, und da ging noch Alles. Moment! Festschrauben!? Ahja, richtig, ich hab die lange Schraube unter dem Objektiv (also auf der Unterseite) reingeschraubt. Mal lösen. Tatsache, kamera meckert nicht mehr und geht an. Also lange Schraube durch eine kurze ersetzt und alles ist perfekt.

Hätt ich bloß dran gedacht, mir zu notieren, welche Schraube wohin gehört ;-)